R1配置:

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#ip address 1.1.1.1 255.255.255.0

IOU1(config-if)#exit

IOU1(config)#router eigrp 100

IOU1(config-router)#network 1.1.1.0 0.0.0.255

IOU1(config-router)#exit

IOU1(config)#key chain R1chain

IOU1(config-keychain)#key 1

IOU1(config-keychain-key)#key-string first

IOU1(config-keychain-key)#exit

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#ip authentication key-chain eigrp 100 R1chain

IOU1(config-if)#ip authentication mode eigrp 100 md5

R2配置:

IOU2(config)#interface ethernet 0/0

IOU2(config-if)#ip address 1.1.1.2 255.255.255.0

IOU2(config-if)#exit

IOU2(config)#router eigrp 100

IOU2(config-router)#network 1.1.1.0 0.0.0.255

IOU2(config-router)#exit

IOU2(config)#key chain R2chain

IOU2(config-keychain)#key 1

IOU2(config-keychain-key)#key-string first

IOU2(config-keychain-key)#exit

IOU2(config)#interface ethernet 0/0

IOU2(config-if)#ip authentication key-chain eigrp 100 R2chain

IOU2(config-if)#ip authentication mode eigrp 100 md5

1、当R1和R2都是key1,且密码都是first时,认证成功.

2、当R1是key1,R2是key2,但密码都是first时,认证失败

3、

R1 key 1 string first

   key 2 string first

R2 key 2 string first

R1成功,R2失败

4、

R1 key 1 string first

   key 2 string first1

R2 key 1 string first

   key 2 string first

R1和R2都成功

5、

R1 key 1 string first

   key 2 string first1

R2 key 1 string first

   key 2 string first

R1和R2都失败

6、

R1 key 2 string first

R2 key 1 string first1

   key 2 string first

R1和R2都失败

因此,EIGRP认证时,Router发送最低ID的key,并携带其ID,只有ID和key完全相同时,才能认证成功。